cve.bz

CVE-2022-37021

9.8 criticalEPSS 2.6%

Critical (9.8) in apache geode. EPSS 2.6% chance of exploitation in the next 30 days. Fixed in org.apache.geode:geode-core 1.12.16, 1.13.5, 1.14.1.

Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.6% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-q4q3-r45f-7gwgMavenorg.apache.geode:geode-core<1.12.161.12.16
GHSA-q4q3-r45f-7gwgMavenorg.apache.geode:geode-core>=1.13.0 <1.13.51.13.5
GHSA-q4q3-r45f-7gwgMavenorg.apache.geode:geode-core>=1.14.0 <1.14.11.14.1

References

Check your stackJSON