cve.bz

CVE-2022-36018

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. If `RaggedTensorToVariant` is given a `rt_nested_splits` list that contains tensors of ranks other than one, it results in a `CHECK` fail that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 88f93dfe691563baa4ae1e80ccde2d5c7a143821. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m6cv-4fmf-66xfPyPItensorflow<2.7.22.7.2
GHSA-m6cv-4fmf-66xfPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-m6cv-4fmf-66xfPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-m6cv-4fmf-66xfPyPItensorflow-cpu<2.7.22.7.2
GHSA-m6cv-4fmf-66xfPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-m6cv-4fmf-66xfPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-m6cv-4fmf-66xfPyPItensorflow-gpu<2.7.22.7.2
GHSA-m6cv-4fmf-66xfPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-m6cv-4fmf-66xfPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1016PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3212PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3348PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON