cve.bz

CVE-2022-36005

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. When `tf.quantization.fake_quant_with_min_max_vars_gradient` receives input `min` or `max` that is nonscalar, it gives a `CHECK` fail that can trigger a denial of service attack. We have patched the issue in GitHub commit f3cf67ac5705f4f04721d15e485e192bb319feed. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r26c-679w-mrjmPyPItensorflow<2.7.22.7.2
GHSA-r26c-679w-mrjmPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-r26c-679w-mrjmPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-r26c-679w-mrjmPyPItensorflow-cpu<2.7.22.7.2
GHSA-r26c-679w-mrjmPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-r26c-679w-mrjmPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-r26c-679w-mrjmPyPItensorflow-gpu<2.7.22.7.2
GHSA-r26c-679w-mrjmPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-r26c-679w-mrjmPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1031PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3234PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3364PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON