cve.bz

CVE-2022-35960

7.5 highEPSS 0.7%

High (7.5) in google tensorflow. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. In `core/kernels/list_kernels.cc's TensorListReserve`, `num_elements` is assumed to be a tensor of size 1. When a `num_elements` of more than 1 element is provided, then `tf.raw_ops.TensorListReserve` fails the `CHECK_EQ` in `CheckIsAlignedAndSingleElement`. We have patched the issue in GitHub commit b5f6fbfba76576202b72119897561e3bd4f179c7. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v5xg-3q2c-c2r4PyPItensorflow<2.7.22.7.2
GHSA-v5xg-3q2c-c2r4PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-v5xg-3q2c-c2r4PyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-v5xg-3q2c-c2r4PyPItensorflow-cpu<2.7.22.7.2
GHSA-v5xg-3q2c-c2r4PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-v5xg-3q2c-c2r4PyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-v5xg-3q2c-c2r4PyPItensorflow-gpu<2.7.22.7.2
GHSA-v5xg-3q2c-c2r4PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-v5xg-3q2c-c2r4PyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1036PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3243PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3370PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON