cve.bz

CVE-2022-35959

7.5 highEPSS 0.5%

High (7.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. The implementation of `AvgPool3DGradOp` does not fully validate the input `orig_input_shape`. This results in an overflow that results in a `CHECK` failure which can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 9178ac9d6389bdc54638ab913ea0e419234d14eb. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wxjj-cgcx-r3vqPyPItensorflow<2.7.22.7.2
GHSA-wxjj-cgcx-r3vqPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-wxjj-cgcx-r3vqPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-wxjj-cgcx-r3vqPyPItensorflow-cpu<2.7.22.7.2
GHSA-wxjj-cgcx-r3vqPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-wxjj-cgcx-r3vqPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-wxjj-cgcx-r3vqPyPItensorflow-gpu<2.7.22.7.2
GHSA-wxjj-cgcx-r3vqPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-wxjj-cgcx-r3vqPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1046PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3257PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3380PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON