cve.bz

CVE-2022-35940

7.5 highEPSS 0.7%

High (7.5) in google tensorflow. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. The `RaggedRangOp` function takes an argument `limits` that is eventually used to construct a `TensorShape` as an `int64`. If `limits` is a very large float, it can overflow when converted to an `int64`. This triggers an `InvalidArgument` but also throws an abort signal that crashes the program. We have patched the issue in GitHub commit 37cefa91bee4eace55715eeef43720b958a01192. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 53% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x989-q2pq-4q5xPyPItensorflow<2.7.22.7.2
GHSA-x989-q2pq-4q5xPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-x989-q2pq-4q5xPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-x989-q2pq-4q5xPyPItensorflow-cpu<2.7.22.7.2
GHSA-x989-q2pq-4q5xPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-x989-q2pq-4q5xPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-x989-q2pq-4q5xPyPItensorflow-gpu<2.7.22.7.2
GHSA-x989-q2pq-4q5xPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-x989-q2pq-4q5xPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1047PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3259PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3381PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON