cve.bz

CVE-2022-35939

9.8 criticalEPSS 0.6%

Critical (9.8) in google tensorflow. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. The `ScatterNd` function takes an input argument that determines the indices of of the output tensor. An input index greater than the output tensor or less than zero will either write content at the wrong index or trigger a crash. We have patched the issue in GitHub commit b4d4b4cb019bd7240a52daa4ba61e3cc814f0384. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-787
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-ffjm-4qwc-7cmfPyPItensorflow<2.7.22.7.2
GHSA-ffjm-4qwc-7cmfPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-ffjm-4qwc-7cmfPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-ffjm-4qwc-7cmfPyPItensorflow-cpu<2.7.22.7.2
GHSA-ffjm-4qwc-7cmfPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-ffjm-4qwc-7cmfPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-ffjm-4qwc-7cmfPyPItensorflow-gpu<2.7.22.7.2
GHSA-ffjm-4qwc-7cmfPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-ffjm-4qwc-7cmfPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-3171PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3319PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-989PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON