cve.bz

CVE-2022-35937

9.1 criticalEPSS 0.6%

Critical (9.1) in google tensorflow. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in tensorflow 2.7.2, 2.8.1, 2.9.1.

TensorFlow is an open source platform for machine learning. The `GatherNd` function takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read is triggered. This issue has been patched in GitHub commit 595a65a3e224a0362d7e68c2213acfc2b499a196. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pxrw-j2fv-hx3hPyPItensorflow<2.7.22.7.2
GHSA-pxrw-j2fv-hx3hPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-pxrw-j2fv-hx3hPyPItensorflow>=2.9.0 <2.9.12.9.1
GHSA-pxrw-j2fv-hx3hPyPItensorflow-cpu<2.7.22.7.2
GHSA-pxrw-j2fv-hx3hPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-pxrw-j2fv-hx3hPyPItensorflow-cpu>=2.9.0 <2.9.12.9.1
GHSA-pxrw-j2fv-hx3hPyPItensorflow-gpu<2.7.22.7.2
GHSA-pxrw-j2fv-hx3hPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
GHSA-pxrw-j2fv-hx3hPyPItensorflow-gpu>=2.9.0 <2.9.12.9.1
PYSEC-2026-1027PyPItensorflow-gpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3226PyPItensorflow<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1
PYSEC-2026-3359PyPItensorflow-cpu<2.7.2
>=2.8.0 <2.8.1
>=2.9.0 <2.9.1
2.7.2, 2.8.1, 2.9.1

References

Check your stackJSON