cve.bz

CVE-2022-34917

7.5 highEPSS 1.5%

High (7.5) in apache kafka. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in org.apache.kafka:kafka 2.8.2, 3.0.2, 3.1.2.

A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWEs
CWE-770, CWE-789
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c9h3-c6qj-hh7qMavenorg.apache.kafka:kafka>=2.8.0 <2.8.22.8.2
GHSA-c9h3-c6qj-hh7qMavenorg.apache.kafka:kafka>=3.0.0 <3.0.23.0.2
GHSA-c9h3-c6qj-hh7qMavenorg.apache.kafka:kafka>=3.1.0 <3.1.23.1.2
GHSA-c9h3-c6qj-hh7qMavenorg.apache.kafka:kafka>=3.2.0 <3.2.33.2.3

References

Check your stackJSON