cve.bz

CVE-2022-31777

5.4 mediumEPSS 1.8%

Medium (5.4) in apache spark. EPSS 1.8% chance of exploitation in the next 30 days. Fixed in pyspark 3.2.2, 3.3.1.

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.8% chance of exploitation in the next 30 days; higher than 78% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-43xg-8wmj-cw8hPyPIpyspark<3.2.23.2.2
GHSA-43xg-8wmj-cw8hPyPIpyspark>=3.3.0 <3.3.13.3.1
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.9.3all versionsno fix published
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.13<3.2.23.2.2
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.13>=3.3.0 <3.3.13.3.1
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.12<3.2.23.2.2
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.12>=3.3.0 <3.3.13.3.1
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.11all versionsno fix published
GHSA-43xg-8wmj-cw8hMavenorg.apache.spark:spark-core_2.10all versionsno fix published
PYSEC-2022-42976PyPIpyspark<3.2.23.2.2

References

Check your stackJSON