cve.bz

CVE-2022-31249

9.8 criticalEPSS 3.8%

Critical (9.8) in suse wrangler. EPSS 3.8% chance of exploitation in the next 30 days. Fixed in github.com/rancher/wrangler 0.7.4-security1, 0.8.11, 0.8.5-security1.

A Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in wrangler of SUSE Rancher allows remote attackers to inject commands in the underlying host via crafted commands passed to Wrangler. This issue affects: SUSE Rancher wrangler version 0.7.3 and prior versions; wrangler version 0.8.4 and prior versions; wrangler version 1.0.0 and prior versions.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.8% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qrg7-hfx7-95c5Gogithub.com/rancher/wrangler<0.7.4-security10.7.4-security1
GHSA-qrg7-hfx7-95c5Gogithub.com/rancher/wrangler>=0.8.0 <0.8.5-security10.8.5-security1
GHSA-qrg7-hfx7-95c5Gogithub.com/rancher/wrangler>=1.0.0 <1.0.11.0.1
GHSA-qrg7-hfx7-95c5Gogithub.com/rancher/wrangler>=0.8.6 <0.8.110.8.11
GO-2023-1519Gogithub.com/rancher/wrangler<0.7.4-security1
>=0.8.0 <0.8.5-security1
>=0.8.6 <0.8.11
>=1.0.0 <1.0.1
0.7.4-security1, 0.8.5-security1, 0.8.11, 1.0.1

References

Check your stackJSON