cve.bz

CVE-2022-31186

3.3 lowEPSS 0.3%

Low (3.3) in next-auth nextauth.js. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in next-auth 3.29.9, 4.10.2.

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

Severity

CVSS 3.1

3.3 low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 17% of CVEs (scores of 2026-10-31)
CWE
CWE-532
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p6mm-27gq-9v3pnpmnext-auth<3.29.93.29.9
GHSA-p6mm-27gq-9v3pnpmnext-auth>=4.0.0 <4.10.24.10.2

References

Check your stackJSON