cve.bz

CVE-2022-31173

7.5 highEPSS 1.7%

High (7.5) in juniper project juniper. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in juniper 0.15.10.

Juniper is a GraphQL server library for Rust. Affected versions of Juniper are vulnerable to uncontrolled recursion resulting in a program crash. This issue has been addressed in version 0.15.10. Users are advised to upgrade. Users unable to upgrade should limit the recursion depth manually.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
CWEs
CWE-674, CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4rx6-g5vg-5f3jcrates.iojuniper<0.15.100.15.10
RUSTSEC-2022-0038crates.iojuniper>=0.0.0-0 <0.15.100.15.10

References

Check your stackJSON