cve.bz

CVE-2022-31172

7.5 highEPSS 0.5%

High (7.5) in openzeppelin contracts. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in @openzeppelin/contracts 4.7.1.

OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 43% of CVEs (scores of 2026-10-31)
CWEs
CWE-347, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4g63-c64m-25w9npm@openzeppelin/contracts>=4.1.0 <4.7.14.7.1
GHSA-4g63-c64m-25w9npm@openzeppelin/contracts-upgradeable>=4.1.0 <4.7.14.7.1

References

Check your stackJSON