cve.bz

CVE-2022-31043

7.5 highEPSS 2.0%

High (7.5). EPSS 2.0% chance of exploitation in the next 30 days. Fixed in guzzlehttp/guzzle 6.5.7, 7.4.4.

Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
2.0% chance of exploitation in the next 30 days; higher than 80% of CVEs (scores of 2026-10-31)
CWEs
CWE-212, CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f2wf-25xc-69c9Packagistguzzlehttp/guzzle>=4.0.0 <6.5.76.5.7
GHSA-f2wf-25xc-69c9Packagistguzzlehttp/guzzle>=7.0.0 <7.4.47.4.4
GHSA-w248-ffj2-4v5qPackagistguzzlehttp/guzzle>=4.0.0 <6.5.76.5.7
GHSA-w248-ffj2-4v5qPackagistguzzlehttp/guzzle>=7.0.0 <7.4.47.4.4

References

Check your stackJSON