cve.bz

CVE-2022-29248

8.1 highEPSS 1.4%

High (8.1). EPSS 1.4% chance of exploitation in the next 30 days. Fixed in guzzlehttp/guzzle 6.5.6, 7.4.3.

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
1.4% chance of exploitation in the next 30 days; higher than 71% of CVEs (scores of 2026-10-31)
CWEs
CWE-565, CWE-200
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cwmx-hcrq-mhc3Packagistguzzlehttp/guzzle<6.5.66.5.6
GHSA-cwmx-hcrq-mhc3Packagistguzzlehttp/guzzle>=7.0.0 <7.4.37.4.3

References

Check your stackJSON