cve.bz

CVE-2022-29216

7.8 highEPSS 0.5%

High (7.8) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, TensorFlow's `saved_model_cli` tool is vulnerable to a code injection. This can be used to open a reverse shell. This code path was maintained for compatibility reasons as the maintainers had several test cases where numpy expressions were used as arguments. However, given that the tool is always run manually, the impact of this is still not severe. The maintainers have now removed the `safe=False` argument, so all parsing is done without calling `eval`. The patch is available in versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-75c9-jrh4-79mcPyPItensorflow<2.6.42.6.4
GHSA-75c9-jrh4-79mcPyPItensorflow-cpu<2.6.42.6.4
GHSA-75c9-jrh4-79mcPyPItensorflow-gpu<2.6.42.6.4
GHSA-75c9-jrh4-79mcPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-75c9-jrh4-79mcPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-75c9-jrh4-79mcPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-75c9-jrh4-79mcPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-75c9-jrh4-79mcPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-75c9-jrh4-79mcPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3125PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3289PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-963PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON