cve.bz

CVE-2022-29213

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the `tf.compat.v1.signal.rfft2d` and `tf.compat.v1.signal.rfft3d` lack input validation and under certain condition can result in crashes (due to `CHECK`-failures). Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 24% of CVEs (scores of 2026-10-31)
CWEs
CWE-617, CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5889-7v45-q28mPyPItensorflow<2.6.42.6.4
GHSA-5889-7v45-q28mPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-5889-7v45-q28mPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-5889-7v45-q28mPyPItensorflow-cpu<2.6.42.6.4
GHSA-5889-7v45-q28mPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-5889-7v45-q28mPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-5889-7v45-q28mPyPItensorflow-gpu<2.6.42.6.4
GHSA-5889-7v45-q28mPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-5889-7v45-q28mPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3107PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3277PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-952PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON