cve.bz

CVE-2022-29212

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, certain TFLite models that were created using TFLite model converter would crash when loaded in the TFLite interpreter. The culprit is that during quantization the scale of values could be greater than 1 but code was always assuming sub-unit scaling. Thus, since code was calling `QuantizeMultiplierSmallerThanOneExp`, the `TFLITE_CHECK_LT` assertion would trigger and abort the process. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 25% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8wwm-6264-x792PyPItensorflow<2.6.42.6.4
GHSA-8wwm-6264-x792PyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-8wwm-6264-x792PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-8wwm-6264-x792PyPItensorflow-cpu<2.6.42.6.4
GHSA-8wwm-6264-x792PyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-8wwm-6264-x792PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-8wwm-6264-x792PyPItensorflow-gpu<2.6.42.6.4
GHSA-8wwm-6264-x792PyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-8wwm-6264-x792PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3141PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3299PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-972PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON