cve.bz

CVE-2022-29211

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.histogram_fixed_width` is vulnerable to a crash when the values array contain `Not a Number` (`NaN`) elements. The implementation assumes that all floating point operations are defined and then converts a floating point result to an integer index. If `values` contains `NaN` then the result of the division is still `NaN` and the cast to `int32` would result in a crash. This only occurs on the CPU implementation. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 25% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xrp2-fhq4-4q3wPyPItensorflow<2.6.42.6.4
GHSA-xrp2-fhq4-4q3wPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-xrp2-fhq4-4q3wPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-xrp2-fhq4-4q3wPyPItensorflow-cpu<2.6.42.6.4
GHSA-xrp2-fhq4-4q3wPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-xrp2-fhq4-4q3wPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-xrp2-fhq4-4q3wPyPItensorflow-gpu<2.6.42.6.4
GHSA-xrp2-fhq4-4q3wPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-xrp2-fhq4-4q3wPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-1048PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3260PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3382PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON