cve.bz

CVE-2022-29209

5.5 mediumEPSS 0.4%

Medium (5.5) in google tensorflow. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 33% of CVEs (scores of 2026-10-31)
CWE
CWE-843
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f4rr-5m7v-wxcwPyPItensorflow<2.6.42.6.4
GHSA-f4rr-5m7v-wxcwPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-f4rr-5m7v-wxcwPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-f4rr-5m7v-wxcwPyPItensorflow-cpu<2.6.42.6.4
GHSA-f4rr-5m7v-wxcwPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-f4rr-5m7v-wxcwPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-f4rr-5m7v-wxcwPyPItensorflow-gpu<2.6.42.6.4
GHSA-f4rr-5m7v-wxcwPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-f4rr-5m7v-wxcwPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3167PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3315PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-986PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON