cve.bz

CVE-2022-29208

7.1 highEPSS 0.4%

High (7.1) in google tensorflow. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.EditDistance` has incomplete validation. Users can pass negative values to cause a segmentation fault based denial of service. In multiple places throughout the code, one may compute an index for a write operation. However, the existing validation only checks against the upper bound of the array. Hence, it is possible to write before the array by massaging the input to generate negative values for `loc`. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-31)
CWE
CWE-787
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-2r2f-g8mw-9gvrPyPItensorflow<2.6.42.6.4
GHSA-2r2f-g8mw-9gvrPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-2r2f-g8mw-9gvrPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-2r2f-g8mw-9gvrPyPItensorflow-cpu<2.6.42.6.4
GHSA-2r2f-g8mw-9gvrPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-2r2f-g8mw-9gvrPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-2r2f-g8mw-9gvrPyPItensorflow-gpu<2.6.42.6.4
GHSA-2r2f-g8mw-9gvrPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-2r2f-g8mw-9gvrPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3088PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3266PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-943PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON