cve.bz

CVE-2022-29207

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, multiple TensorFlow operations misbehave in eager mode when the resource handle provided to them is invalid. In graph mode, it would have been impossible to perform these API calls, but migration to TF 2.x eager mode opened up this vulnerability. If the resource handle is empty, then a reference is bound to a null pointer inside TensorFlow codebase (various codepaths). This is undefined behavior. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 25% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-475
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5wpj-c6f7-24x8PyPItensorflow<2.6.42.6.4
GHSA-5wpj-c6f7-24x8PyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-5wpj-c6f7-24x8PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-5wpj-c6f7-24x8PyPItensorflow-cpu<2.6.42.6.4
GHSA-5wpj-c6f7-24x8PyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-5wpj-c6f7-24x8PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-5wpj-c6f7-24x8PyPItensorflow-gpu<2.6.42.6.4
GHSA-5wpj-c6f7-24x8PyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-5wpj-c6f7-24x8PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-3112PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3280PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-955PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON