cve.bz

CVE-2022-29204

5.5 mediumEPSS 0.4%

Medium (5.5) in google tensorflow. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.UnsortedSegmentJoin` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `num_segments` is a positive scalar but there is no validation. Since this value is used to allocate the output tensor, a negative value would result in a `CHECK`-failure (assertion failure), as per TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-191
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hx9q-2mx4-m4pgPyPItensorflow<2.6.42.6.4
GHSA-hx9q-2mx4-m4pgPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-hx9q-2mx4-m4pgPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-hx9q-2mx4-m4pgPyPItensorflow-cpu<2.6.42.6.4
GHSA-hx9q-2mx4-m4pgPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-hx9q-2mx4-m4pgPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-hx9q-2mx4-m4pgPyPItensorflow-gpu<2.6.42.6.4
GHSA-hx9q-2mx4-m4pgPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-hx9q-2mx4-m4pgPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-1010PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3203PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3342PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON