cve.bz

CVE-2022-29203

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SpaceToBatchND` (in all backends such as XLA and handwritten kernels) is vulnerable to an integer overflow: The result of this integer overflow is used to allocate the output tensor, hence we get a denial of service via a `CHECK`-failure (assertion failure), as in TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-jjm6-4vf7-cjh4PyPItensorflow<2.6.42.6.4
GHSA-jjm6-4vf7-cjh4PyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-jjm6-4vf7-cjh4PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-jjm6-4vf7-cjh4PyPItensorflow-cpu<2.6.42.6.4
GHSA-jjm6-4vf7-cjh4PyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-jjm6-4vf7-cjh4PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-jjm6-4vf7-cjh4PyPItensorflow-gpu<2.6.42.6.4
GHSA-jjm6-4vf7-cjh4PyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-jjm6-4vf7-cjh4PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-1012PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3207PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3344PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON