cve.bz

CVE-2022-29199

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.LoadAndRemapMatrix does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `initializing_values` is a vector but there is no validation for this before accessing its value. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 25% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p9rc-rmr5-529jPyPItensorflow<2.6.42.6.4
GHSA-p9rc-rmr5-529jPyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-p9rc-rmr5-529jPyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-p9rc-rmr5-529jPyPItensorflow-cpu<2.6.42.6.4
GHSA-p9rc-rmr5-529jPyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-p9rc-rmr5-529jPyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-p9rc-rmr5-529jPyPItensorflow-gpu<2.6.42.6.4
GHSA-p9rc-rmr5-529jPyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-p9rc-rmr5-529jPyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-1025PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3221PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3357PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON