cve.bz

CVE-2022-29198

5.5 mediumEPSS 0.3%

Medium (5.5) in google tensorflow. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.4, 2.7.2, 2.8.1.

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SparseTensorToCSRSparseMatrix` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `dense_shape` is a vector and `indices` is a matrix (as part of requirements for sparse tensors) but there is no validation for this. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 25% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mg66-qvc5-rm93PyPItensorflow<2.6.42.6.4
GHSA-mg66-qvc5-rm93PyPItensorflow>=2.7.0 <2.7.22.7.2
GHSA-mg66-qvc5-rm93PyPItensorflow>=2.8.0 <2.8.12.8.1
GHSA-mg66-qvc5-rm93PyPItensorflow-cpu<2.6.42.6.4
GHSA-mg66-qvc5-rm93PyPItensorflow-cpu>=2.7.0 <2.7.22.7.2
GHSA-mg66-qvc5-rm93PyPItensorflow-cpu>=2.8.0 <2.8.12.8.1
GHSA-mg66-qvc5-rm93PyPItensorflow-gpu<2.6.42.6.4
GHSA-mg66-qvc5-rm93PyPItensorflow-gpu>=2.7.0 <2.7.22.7.2
GHSA-mg66-qvc5-rm93PyPItensorflow-gpu>=2.8.0 <2.8.12.8.1
PYSEC-2026-1018PyPItensorflow-gpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3214PyPItensorflow<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1
PYSEC-2026-3350PyPItensorflow-cpu<2.6.4
>=2.7.0 <2.7.2
>=2.8.0 <2.8.1
2.6.4, 2.7.2, 2.8.1

References

Check your stackJSON