cve.bz

CVE-2022-29036

5.4 mediumEPSS 72%

Medium (5.4) in jenkins credentials. EPSS 72% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:credentials 1074.1076.v39c30cecb_0e2, 1087.1089.v2f1b_9a_b_040e4, 2.6.1.1.

Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
72% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rvg5-f5fj-mxvgMavenorg.jenkins-ci.plugins:credentials<2.6.1.12.6.1.1
GHSA-rvg5-f5fj-mxvgMavenorg.jenkins-ci.plugins:credentials>=2.6.2 <1074.1076.v39c30cecb_0e21074.1076.v39c30cecb_0e2
GHSA-rvg5-f5fj-mxvgMavenorg.jenkins-ci.plugins:credentials>=1087.v16065d268466 <1087.1089.v2f1b_9a_b_040e41087.1089.v2f1b_9a_b_040e4
GHSA-rvg5-f5fj-mxvgMavenorg.jenkins-ci.plugins:credentials>=1105 <=1111.v35ano fix published

References

Check your stackJSON