cve.bz

CVE-2022-25927

7.5 highEPSS 1.7%

High (7.5) in ua-parser-js project ua-parser-js. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in ua-parser-js 0.7.33, 1.0.33.

Versions of the package ua-parser-js from 0.7.30 and before 0.7.33, from 0.8.1 and before 1.0.33 are vulnerable to Regular Expression Denial of Service (ReDoS) via the trim() function.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
CWE
CWE-1333
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fhg7-m89q-25r3npmua-parser-js>=0.7.30 <0.7.330.7.33
GHSA-fhg7-m89q-25r3npmua-parser-js>=0.8.0 <1.0.331.0.33

References

Check your stackJSON