cve.bz

CVE-2022-25875

6.1 mediumEPSS 1.4%

Medium (6.1) in svelte svelte. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in svelte 3.49.0.

The package svelte before 3.49.0 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization and to improper escape of attributes when using objects during SSR (Server-Side Rendering). Exploiting this vulnerability is possible via objects with a custom toString() function.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.4% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wv8q-r932-8hc7npmsvelte<3.49.03.49.0

References

Check your stackJSON