Critical (9.8) in simple-git project simple-git. EPSS 2.7% chance of exploitation in the next 30 days. Fixed in simple-git 3.16.0.
Versions of the package simple-git before 3.16.0 are vulnerable to Remote Code Execution (RCE) via the clone(), pull(), push() and listRemote() methods, due to improper input sanitization.
This vulnerability exists due to an incomplete fix of [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221).
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.7% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)