cve.bz

CVE-2022-25858

7.5 highEPSS 3.3%

High (7.5) in terser terser. EPSS 3.3% chance of exploitation in the next 30 days. Fixed in terser 4.8.1, 5.14.2.

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
3.3% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
CWE
CWE-1333
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4wf5-vphf-c2xcnpmterser<4.8.14.8.1
GHSA-4wf5-vphf-c2xcnpmterser>=5.0.0 <5.14.25.14.2

References

Check your stackJSON