cve.bz

CVE-2022-25857

7.5 highEPSS 2.9%

High (7.5). EPSS 2.9% chance of exploitation in the next 30 days. Fixed in org.yaml:snakeyaml 1.31.

The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.9% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-776
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3mc7-4q67-w48mMavenorg.yaml:snakeyaml<1.311.31

References

Check your stackJSON