cve.bz

CVE-2022-25647

7.5 highEPSS 12%

High (7.5). EPSS 12% chance of exploitation in the next 30 days. Fixed in com.google.code.gson:gson 2.8.9.

The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
12% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4jrv-ppp4-jm57Mavencom.google.code.gson:gson<2.8.92.8.9

References

Check your stackJSON