cve.bz

CVE-2022-25303

6.1 mediumEPSS 1.0%

Medium (6.1) in whoogle-search project whoogle-search. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in whoogle-search 0.7.2.

The package whoogle-search before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the error_message that is then rendered in the error.html template, using the [flask.render_template](https://flask.palletsprojects.com/en/2.1.x/api/flask.render_template) function. However, the error_message is rendered using the [| safe filter](https://jinja.palletsprojects.com/en/3.1.x/templates/working-with-automatic-escaping), meaning the user input is not escaped.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 61% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mxvc-fwgx-j778PyPIwhoogle-search<0.7.20.7.2
PYSEC-2022-226PyPIwhoogle-search<0.7.20.7.2

References

Check your stackJSON