cve.bz

CVE-2022-25231

7.5 highEPSS 1.3%

High (7.5) in node-opcua project node-opcua. EPSS 1.3% chance of exploitation in the next 30 days. Fixed in node-opcua 2.74.0.

The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) by sending a specifically crafted OPC UA message with a special OPC UA NodeID, when the requested memory allocation exceeds the v8’s memory limit.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.3% chance of exploitation in the next 30 days; higher than 70% of CVEs (scores of 2026-10-31)
CWE
CWE-770
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qpgc-xh7j-52q8npmnode-opcua<2.74.02.74.0

References

Check your stackJSON