cve.bz

CVE-2022-24836

7.5 highEPSS 3.5%

High (7.5). EPSS 3.5% chance of exploitation in the next 30 days. Fixed in nokogiri 1.13.4.

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri `< v1.13.4` contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri `>= 1.13.4`. There are no known workarounds for this issue.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
3.5% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWEs
CWE-1333, CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-crjr-9rc5-ghw8RubyGemsnokogiri<1.13.41.13.4

References

Check your stackJSON