cve.bz

CVE-2022-24722

6.1 mediumEPSS 1.1%

Medium (6.1) in github viewcomponent. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in view_component 2.31.2, 2.49.1.

VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.1% chance of exploitation in the next 30 days; higher than 65% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cm9w-c4rj-r2cfRubyGemsview_component>=2.31.0 <2.31.22.31.2
GHSA-cm9w-c4rj-r2cfRubyGemsview_component>=2.32.0 <2.49.12.49.1

References

Check your stackJSON