cve.bz

CVE-2022-24440

9.8 criticalEPSS 2.6%

Critical (9.8) in cocoapods cocoapods-downloader. EPSS 2.6% chance of exploitation in the next 30 days. Fixed in cocoapods-downloader 1.6.0, 1.6.3.

The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.6% chance of exploitation in the next 30 days; higher than 85% of CVEs (scores of 2026-10-31)
CWE
CWE-88
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7627-mp87-jf6qRubyGemscocoapods-downloader<1.6.01.6.0
GHSA-7627-mp87-jf6qRubyGemscocoapods-downloader>=1.6.2 <1.6.31.6.3

References

Check your stackJSON