cve.bz

CVE-2022-24280

6.5 mediumEPSS 1.5%

Medium (6.5) in apache pulsar. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in org.apache.pulsar:pulsar 2.7.5, 2.8.3, 2.9.2.

Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3mg9-m3f6-v7fqMavenorg.apache.pulsar:pulsar<2.7.52.7.5
GHSA-3mg9-m3f6-v7fqMavenorg.apache.pulsar:pulsar>=2.8.0 <2.8.32.8.3
GHSA-3mg9-m3f6-v7fqMavenorg.apache.pulsar:pulsar>=2.9.0 <2.9.22.9.2

References

Check your stackJSON