cve.bz

CVE-2022-23708

4.3 mediumEPSS 1.0%

Medium (4.3) in elastic elasticsearch. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in org.elasticsearch:elasticsearch 7.17.1.

A flaw was discovered in Elasticsearch 7.17.0’s upgrade assistant, in which upgrading from version 6.x to 7.x would disable the in-built protections on the security index, allowing authenticated users with “*” index permissions access to this index.

Severity

CVSS 3.1

4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 63% of CVEs (scores of 2026-10-31)
CWE
CWE-264
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pgq6-ccqj-hpqrMavenorg.elasticsearch:elasticsearch>=7.16.0 <7.17.17.17.1

References

Check your stackJSON