cve.bz

CVE-2022-23646

7.5 highEPSS 1.8%

High (7.5) in vercel next.js. EPSS 1.8% chance of exploitation in the next 30 days. Fixed in next 12.1.0.

Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
1.8% chance of exploitation in the next 30 days; higher than 78% of CVEs (scores of 2026-11-01)
CWE
CWE-451
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fmvm-x8mv-47mjnpmnext>=10.0.0 <12.1.012.1.0

References

Check your stackJSON