cve.bz

CVE-2022-23623

8.8 highEPSS 1.2%

High (8.8) in frourio frourio. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in frourio 0.26.0.

Frourio is a full stack framework, for TypeScript. Frourio users who uses frourio version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-1321
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8xxm-h73r-ghfjnpmfrourio<0.26.00.26.0

References

Check your stackJSON