cve.bz

CVE-2022-23588

6.5 mediumEPSS 0.9%

Medium (6.5) in google tensorflow. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. A malicious user can cause a denial of service by altering a `SavedModel` such that Grappler optimizer would attempt to build a tensor using a reference `dtype`. This would result in a crash due to a `CHECK`-fail in the `Tensor` constructor as reference types are not allowed. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 58% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-fx5c-h9f6-rv7cPyPItensorflow<2.5.32.5.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-fx5c-h9f6-rv7cPyPItensorflow-cpu<2.5.32.5.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-fx5c-h9f6-rv7cPyPItensorflow-gpu<2.5.32.5.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-fx5c-h9f6-rv7cPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-152PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-97PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3181PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON