cve.bz

CVE-2022-23587

9.8 criticalEPSS 0.9%

Critical (9.8) in google tensorflow. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. Under certain scenarios, Grappler component of TensorFlow is vulnerable to an integer overflow during cost estimation for crop and resize. Since the cropping parameters are user controlled, a malicious person can trigger undefined behavior. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8jj7-5vxc-pg2qPyPItensorflow<2.5.32.5.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-8jj7-5vxc-pg2qPyPItensorflow-cpu<2.5.32.5.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-8jj7-5vxc-pg2qPyPItensorflow-gpu<2.5.32.5.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-8jj7-5vxc-pg2qPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-151PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-96PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3137PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON