cve.bz

CVE-2022-23582

6.5 mediumEPSS 0.8%

Medium (6.5) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. A malicious user can cause a denial of service by altering a `SavedModel` such that `TensorByteSize` would trigger `CHECK` failures. `TensorShape` constructor throws a `CHECK`-fail if shape is partial or has a number of elements that would overflow the size of an `int`. The `PartialTensorShape` constructor instead does not cause a `CHECK`-abort if the shape is partial, which is exactly what this function needs to be able to return `-1`. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 56% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4j82-5ccr-4r8vPyPItensorflow<2.5.32.5.3
GHSA-4j82-5ccr-4r8vPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-4j82-5ccr-4r8vPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-4j82-5ccr-4r8vPyPItensorflow-cpu<2.5.32.5.3
GHSA-4j82-5ccr-4r8vPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-4j82-5ccr-4r8vPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-4j82-5ccr-4r8vPyPItensorflow-gpu<2.5.32.5.3
GHSA-4j82-5ccr-4r8vPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-4j82-5ccr-4r8vPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-146PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-91PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3100PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON