cve.bz

CVE-2022-23579

6.5 mediumEPSS 0.8%

Medium (6.5) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The Grappler optimizer in TensorFlow can be used to cause a denial of service by altering a `SavedModel` such that `SafeToRemoveIdentity` would trigger `CHECK` failures. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-11-01)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5f2r-qp73-37mrPyPItensorflow<2.5.32.5.3
GHSA-5f2r-qp73-37mrPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-5f2r-qp73-37mrPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-5f2r-qp73-37mrPyPItensorflow-cpu<2.5.32.5.3
GHSA-5f2r-qp73-37mrPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-5f2r-qp73-37mrPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-5f2r-qp73-37mrPyPItensorflow-gpu<2.5.32.5.3
GHSA-5f2r-qp73-37mrPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-5f2r-qp73-37mrPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-143PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-88PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3108PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON