cve.bz

CVE-2022-23569

6.5 mediumEPSS 0.5%

Medium (6.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. Multiple operations in TensorFlow can be used to trigger a denial of service via `CHECK`-fails (i.e., assertion failures). This is similar to TFSA-2021-198 and has similar fixes. We have patched the reported issues in multiple GitHub commits. It is possible that other similar instances exist in TensorFlow, we will issue fixes as these are discovered. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qj5r-f9mv-rffhPyPItensorflow<2.5.32.5.3
GHSA-qj5r-f9mv-rffhPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-qj5r-f9mv-rffhPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-qj5r-f9mv-rffhPyPItensorflow-cpu<2.5.32.5.3
GHSA-qj5r-f9mv-rffhPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-qj5r-f9mv-rffhPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-qj5r-f9mv-rffhPyPItensorflow-gpu<2.5.32.5.3
GHSA-qj5r-f9mv-rffhPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-qj5r-f9mv-rffhPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-133PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-78PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3230PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON