cve.bz

CVE-2022-23567

6.5 mediumEPSS 1.1%

Medium (6.5) in google tensorflow. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The implementations of `Sparse*Cwise*` ops are vulnerable to integer overflows. These can be used to trigger large allocations (so, OOM based denial of service) or `CHECK`-fails when building new `TensorShape` objects (so, assert failures based denial of service). We are missing some validation on the shapes of the input tensors as well as directly constructing a large `TensorShape` with user-provided dimensions. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 65% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rrx2-r989-2c43PyPItensorflow<2.5.32.5.3
GHSA-rrx2-r989-2c43PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-rrx2-r989-2c43PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-rrx2-r989-2c43PyPItensorflow-cpu<2.5.32.5.3
GHSA-rrx2-r989-2c43PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-rrx2-r989-2c43PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-rrx2-r989-2c43PyPItensorflow-gpu<2.5.32.5.3
GHSA-rrx2-r989-2c43PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-rrx2-r989-2c43PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-131PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-76PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3240PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON