cve.bz

CVE-2022-23566

8.8 highEPSS 0.9%

High (8.8) in google tensorflow. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. TensorFlow is vulnerable to a heap OOB write in `Grappler`. The `set_output` function writes to an array at the specified index. Hence, this gives a malicious user a write primitive. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWE
CWE-787
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5qw5-89mw-wcg2PyPItensorflow<2.5.32.5.3
GHSA-5qw5-89mw-wcg2PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-5qw5-89mw-wcg2PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-5qw5-89mw-wcg2PyPItensorflow-cpu<2.5.32.5.3
GHSA-5qw5-89mw-wcg2PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-5qw5-89mw-wcg2PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-5qw5-89mw-wcg2PyPItensorflow-gpu<2.5.32.5.3
GHSA-5qw5-89mw-wcg2PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-5qw5-89mw-wcg2PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-130PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-75PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3109PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON